Personal Forums

General Discussion

RSS Feed

OAuth "update" parameter not working

    • Enreeco
    • Topic created 4 years ago

    The system seems not to account the "update" parameter in the authorization token request. I'm always redirected to Personal Grant Permission page, even if I've granted that permission several times. How is it possibile?

    Message edited by Enreeco 4 years ago

    Tags

  1. Alex Levin4 years ago

    Did you set the update parameter to false like this: &update=false

  2. Enreeco4 years ago

    sure!

  3. Enreeco4 years ago

    any suggestions?

  4. koshi4 years ago

    Hi Enreeco! Did you change scope parameter between requests?

  5. koshi4 years ago

    Hi Enreeco! Did you change scope parameter between requests?

  6. Enreeco4 years ago

    ooops I missed your response....no they are always the same...this is what I'm doint right now:

    https://api-sandbox.personal.com/oauth/authorize?client_id=[CLIENT_ID]&response_type=code&redirect_uri=http%3A%2F%2Flocalhost%3A9000%2FpersonalCallback&scope=read_0001,read_0000,read_0037,read_0040,read_0044,read_0108,grant_004

    I use it several times (by simple browsing)...the strange thing is that 2 days ago it worked well.

  7. Enreeco4 years ago

    If i use only one scope, e.g. scope=read_0001 it works perfectly...what am I missing? Using multiple scopes is documented and the synthax seems correct: scope=0001_read,0001_create,xxxx_permission

  8. Enreeco4 years ago

    sorry....I meant scope=read_0001,create_0001,permission_xxxx

  9. Alex Levin4 years ago

    Very interesting. One thing I see - the last grant is missing a 0 - it should be grant_0040. Let me know if that changes anything.

  10. Enreeco4 years ago

    the strange thing is that if I use only one scope, it works

  11. Enreeco4 years ago

    is there something wrong in that URL?

  12. Enreeco4 years ago

    Found it...may a bug? The problem is related to the 0001 GEM: if I remove the read_0001 all works perfectly? Is there a reason?

  13. koshi4 years ago

    Hey Enreeco! Your URL seems fine. We'll look at the 0001 GEM thing ASAP. Thanks for the info!

  14. Enreeco4 years ago

    Thank you!

  15. koshi4 years ago

    also, we'll be reseting sandbox server for maintenance over next couple of hours, so don't be alarmed if you get 504 on occasion.

  16. Enreeco4 years ago

    Thanks for the advise

[ Page 1 of 1 ]